using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^)((?<=[a-z])[A-Z0-9]|[A-Z](?=[a-z]))";
string substitution = @"_\1";
string input = @"Situacao"",
PES_TIPO_PESSOA"",
CedenteCnpjCpf"",
TIT_CEDENTE_ENT_CODIGO"",
CedenteNome"",
Cnae"",
SecaoCNAEDescricao"",
NotaPdd"",
SAC_TIPO_PESSOA"",
SacadoCnpjCpf"",
SacadoNome"",
IdTituloVortx"",
TipoAtivo"",
DataEmissao"",
DataAquisicao"",
DataVencimento"",
NumeroBoleto"",
NumeroTitulo"",
CampoChave"",
ValorAquisicao"",
ValorNominal"",
ValorPresente"",
PDDNota"",
PDDVencido"",
PagamentoParcial"",
Coobricacao"",
DataGeracao"",
PDDTotal"",
CampoAdicional1"",
CampoAdicional2"",
CampoAdicional3"",
CampoAdicional4"",
CampoAdicional5,
Campo22Adicional5
camelCase";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}