use strict;
my $str = 'Situacao",
PES_TIPO_PESSOA",
CedenteCnpjCpf",
TIT_CEDENTE_ENT_CODIGO",
CedenteNome",
Cnae",
SecaoCNAEDescricao",
NotaPdd",
SAC_TIPO_PESSOA",
SacadoCnpjCpf",
SacadoNome",
IdTituloVortx",
TipoAtivo",
DataEmissao",
DataAquisicao",
DataVencimento",
NumeroBoleto",
NumeroTitulo",
CampoChave",
ValorAquisicao",
ValorNominal",
ValorPresente",
PDDNota",
PDDVencido",
PagamentoParcial",
Coobricacao",
DataGeracao",
PDDTotal",
CampoAdicional1",
CampoAdicional2",
CampoAdicional3",
CampoAdicional4",
CampoAdicional5,
Campo22Adicional5
camelCase';
my $regex = qr/(?<!^)((?<=[a-z])[A-Z0-9]|[A-Z](?=[a-z]))/mp;
my $subst = '_\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";