import re
regex = re.compile(r"^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$", flags=re.MULTILINE)
test_str = ("http://wikirace.example.org\n"
"https://wikirace.example.org/\n"
"https://wikirace.example.org/party/asdfghj\n"
"https://wikirace.example.org/party/asdfghj/game\n"
"https://wikirace.example.org/party/asdfghj/results\n\n"
"https://example.org/wikirace/\n"
"http://example.org/wikirace/party\n"
"http://example.org/wikirace/game\n"
"https://wikirace.example.org/game/fghjhkl\n"
"https://example.org/wikirace/game/fghjhkl")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")