$re = '/\b[^(]+\b|\([^(]*(?:\([^(]*\)[^(]*)*\)/';
$str = '(S)42B7O(P)GX64000700(D)20433(R)B(1L)022
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);