re = /\b[^(]+\b|\([^(]*(?:\([^(]*\)[^(]*)*\)/
str = '(S)42B7O(P)GX64000700(D)20433(R)B(1L)022
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end