import re
regex = re.compile(r"\b[^(]+\b|\([^(]*(?:\([^(]*\)[^(]*)*\)")
test_str = ("(S)42B7O(P)GX64000700(D)20433(R)B(1L)022\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")