#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\D)(\d{14})(?:\D|$)"
Local $sString = "12345678901234*300 OK" & @CRLF & _
"" & @CRLF & _
"12345678901234x21 OK" & @CRLF & _
"" & @CRLF & _
"*123456789012345*300 NOT OK" & @CRLF & _
"" & @CRLF & _
"12345678901234 OK" & @CRLF & _
"" & @CRLF & _
"123456789012345 NOT OK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")