import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\D)(\\d{14})(?:\\D|$)";
final String string = "12345678901234*300 OK\n\n"
+ "12345678901234x21 OK\n\n"
+ "*123456789012345*300 NOT OK\n\n"
+ "12345678901234 OK\n\n"
+ "123456789012345 NOT OK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}