re = /(?:^|\D)(\d{14})(?:\D|$)/m
str = '12345678901234*300 OK
12345678901234x21 OK
*123456789012345*300 NOT OK
12345678901234 OK
123456789012345 NOT OK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end