package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s(),=]+(?:\s*=\s*[^\s(),=]+)?`)
var str = `my-app command, arg1 arg2 arg3 =val1, arg4 = val2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}