const regex = /[^\s(),=]+(?:\s*=\s*[^\s(),=]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s(),=]+(?:\\s*=\\s*[^\\s(),=]+)?', 'gm')
const str = `my-app command, arg1 arg2 arg3 =val1, arg4 = val2)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}