$re = '/[^\s(),=]+(?:\s*=\s*[^\s(),=]+)?/m';
$str = 'my-app command, arg1 arg2 arg3 =val1, arg4 = val2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);