use strict;
my $str = 'Foo 1.2.3.4.5 bar
Foo 111111.2..3.4.5
Foo 10.. bar';
my $regex = qr/(?<=\s|^)\d+(?:\.\d+)*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}