re = /(?<=\s|^)\d+(?:\.\d+)*/mi
str = 'Foo 1.2.3.4.5 bar
Foo 111111.2..3.4.5
Foo 10.. bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end