$re = '/(?<=\s|^)\d+(?:\.\d+)*/mi';
$str = 'Foo 1.2.3.4.5 bar
Foo 111111.2..3.4.5
Foo 10.. bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);