$re = '/\s([\-\+\!]?)([\-\+\!]?)(?:([\'"])(.+?)\3)|([\-\+\!]?[\w\-#@\/\(\)]+)/';
$str = '+@bob "xxx",\'yyy\', "freak\'d out" -\'bob two\' "" can I #handle/children -#nope @ok(42)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);