re = /\s([\-\+\!]?)([\-\+\!]?)(?:([\'"])(.+?)\3)|([\-\+\!]?[\w\-#@\/\(\)]+)/
str = '+@bob "xxx",\'yyy\', "freak\'d out" -\'bob two\' "" can I #handle/children -#nope @ok(42)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end