package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<type>BORDER)(?:::)(?P<desc>[\w#()/]*)`)
var str = `BORDER::APPLE_PEERING_GROUP_1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}