$re = '/\".*_followed_by\":\s+{\s+\".*":\s([\d]{4})\s+}/';
$str = '"edge_followed_by": {
"count": 3296
},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);