// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\".*_followed_by\":\s+{\s+\".*":\s([\d]{4})\s+}"#).unwrap();
let string = "\"edge_followed_by\": {
\"count\": 3296
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}