using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=""[^""]*(?<=""|\s)col-xs-9(?=""|\s[^>]*)"">(?<name>[^<]*)";
string input = @"<div class=""top_seller_name col-xs-9"">
Yusuf
<div class=""sprite_view_icn_whatsapp top_seller_whatsapp_sprite"">
<div class=""top_seller_whatsapp"">WhatsApp Preferred</div>
</div>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}