import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"[^\"]*(?<=\"|\\s)col-xs-9(?=\"|\\s[^>]*)\">(?<name>[^<]*)";
final String string = "<div class=\"top_seller_name col-xs-9\">\n"
+ " Yusuf\n"
+ " \n"
+ " \n"
+ " <div class=\"sprite_view_icn_whatsapp top_seller_whatsapp_sprite\">\n"
+ " <div class=\"top_seller_whatsapp\">WhatsApp Preferred</div>\n"
+ " </div>\n"
+ " \n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}