#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(?<![-_])\.(?![-_]).*$"
Local $sString = "aaa . aaa" & @CRLF & _
"aaa ._ aaa" & @CRLF & _
"aa .- aaa" & @CRLF & _
"aa -. aaa" & @CRLF & _
"aaa _. aaa" & @CRLF & _
"aaa -.- aa" & @CRLF & _
"aaa _._ aaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")