using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?<![-_])\.(?![-_]).*$";
string input = @"aaa . aaa
aaa ._ aaa
aa .- aaa
aa -. aaa
aaa _. aaa
aaa -.- aa
aaa _._ aaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}