$re = '/^.*(?<![-_])\.(?![-_]).*$/m';
$str = 'aaa . aaa
aaa ._ aaa
aa .- aaa
aa -. aaa
aaa _. aaa
aaa -.- aa
aaa _._ aaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);