package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:-\d+)?')? (\D+) (\d+)`)
var str = `20' Container 1, 40' Open Container 1, 40-45' Closed Container 3, container roll 10, container lift 50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}