re = /(\d+(?:-\d+)?')? (\D+) (\d+)/
str = '20\' Container 1, 40\' Open Container 1, 40-45\' Closed Container 3, container roll 10, container lift 50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end