using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">> ([a-zA-Z ]+)(?=:)";
string input = @">> John doe: Hello, I am John Doe. >> Hello, I am Jane Doe. >> Thank you for coming, we will start in two minutes. >> Sam Smith: [no audio] Good morning, everyone.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}