#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)очень хороший"
Local $sString = "Привет! я попыталься написать регулярку но хз смог ли правильно)" & @CRLF & _
"очень хороший человек едет на отдых в хорошую страну, и ему очень хорошо" & @CRLF & _
"" & @CRLF & _
"В выводе просто бери match1 (То есть первый найденный элемент)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")