$re = '/очень хороший/m';
$str = 'Привет! я попыталься написать регулярку но хз смог ли правильно)
очень хороший человек едет на отдых в хорошую страну, и ему очень хорошо
В выводе просто бери match1 (То есть первый найденный элемент)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);