// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)очень хороший").unwrap();
let string = "Привет! я попыталься написать регулярку но хз смог ли правильно)
очень хороший человек едет на отдых в хорошую страну, и ему очень хорошо
В выводе просто бери match1 (То есть первый найденный элемент)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}