const regex = new RegExp('(.)(.*?)\\1', 'g')
const str = `abbcabb
abca`;
const subst = `\g<2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);