$re = '/(.)(.*?)\1/';
$str = 'abbcabb
abca';
$subst = "\g<2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;