use strict;
my $str = 'abbcabb
abca';
my $regex = qr/(.)(.*?)\1/p;
my $subst = '\\g<2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";