import re
regex = re.compile(r"(.)(.*?)*?\1")
test_str = ("abbcabb\n"
"abca")
subst = "\\g<2>"
result = regex.sub(subst, test_str)
if result:
print(result)