import re
regex = re.compile(r"'([^']+)'=", flags=re.MULTILINE)
test_str = "'Key'='Value', 'Key'='Value', 'Key'='Value', 'Key'='Value'"
subst = "\\1="
result = regex.sub(subst, test_str)
if result:
print(result)