re = /'([^']+)'=/m
str = '\'Key\'=\'Value\', \'Key\'=\'Value\', \'Key\'=\'Value\', \'Key\'=\'Value\''
subst = '\\1='
result = str.gsub(re, subst)
# Print the result of the substitution
puts result