#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Diagnostic-Code:\K.*(?:\R(?!Diagnostic-Code:).*)*"
Local $sString = "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does" & @CRLF & _
" not exist. Please try 550-5.1.1 double-checking the recipient's email" & @CRLF & _
" address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1" & @CRLF & _
" https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp" & @CRLF & _
"" & @CRLF & _
"Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does" & @CRLF & _
" not exist. Please try 550-5.1.1 double-checking the recipient's email" & @CRLF & _
" address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1" & @CRLF & _
" https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")