import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Diagnostic-Code:\\K.*(?:\\R(?!Diagnostic-Code:).*)*";
final String string = "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does\n"
+ " not exist. Please try 550-5.1.1 double-checking the recipient's email\n"
+ " address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1\n"
+ " https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp\n\n"
+ "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does\n"
+ " not exist. Please try 550-5.1.1 double-checking the recipient's email\n"
+ " address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1\n"
+ " https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}