const regex = /(?!\A)^.*\Z/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\A)^.*\\Z', 'ms')
const str = `RC,200,OK
LoginSuccessful,1111111111111,ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}