$re = '/(?!\A)^.*\Z/ms';
$str = 'RC,200,OK
LoginSuccessful,1111111111111,ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);