re = /(?!\A)^.*\Z/m
str = 'RC,200,OK
LoginSuccessful,1111111111111,ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ'
# Print the match result
str.match(re) do |match|
puts match.to_s
end