using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{3}\K";
string substitution = @"\n";
string input = @"saahaalaasabaaboabsabyaceactaddadoadsadzaf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}