$re = '/.{3}\K/m';
$str = 'saahaalaasabaaboabsabyaceactaddadoadsadzaf';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;