use strict;
my $str = 'saahaalaasabaaboabsabyaceactaddadoadsadzaf';
my $regex = qr/.{3}\K/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";