#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^,\r\n]*,){6}.*\r?\n(?:[^,\r\n]*,){9}.*(?:\r?\n(?!(?:[^,\r\n]*,){6}.*\r?\n(?:[^,\r\n]*,){9}).*)*"
Local $sString = "LB,32736,0,T,NRJ.POMPES_BACHE.PUISSANCE_ELEC_INST,20190811T080000.000Z,20190811T194400.000Z" & @CRLF & _
"TR,NRJ.POMPES_BACHE.PUISSANCE_ELEC_INST,0,65535,1,1,,0,0,2" & @CRLF & _
"20190811T080000.000Z,0.00800000037997961,192" & @CRLF & _
"20190811T080100.000Z,0.008999999612569809,192" & @CRLF & _
"20190811T080200.000Z,0.008999999612569809,192" & @CRLF & _
"LB,32734,0,T,NRJ.POMPES_BACHE.PUISSANCE_ELEC_CPT,20190811T080000.000Z,20190811T201200.000Z" & @CRLF & _
"TR,NRJ.POMPES_BACHE.PUISSANCE_ELEC_CPT,0,65535,1,1,,0,0,2" & @CRLF & _
"20190811T080000.000Z,0.6743068099021912,192" & @CRLF & _
"20190811T080100.000Z,0.6744459867477417,192" & @CRLF & _
"20190811T080200.000Z,0.6745882630348206,192" & @CRLF & _
"20190811T080300.000Z,0.6747232675552368,192" & @CRLF & _
"20190811T080400.000Z,0.6748600006103516,192" & @CRLF & _
"20190811T080500.000Z,0.6749916672706604,192" & @CRLF & _
"20190811T080600.000Z,0.6751362681388855,192" & @CRLF & _
"" & @CRLF & _
"1,2,3,4,5,6,7" & @CRLF & _
"1,2,3,4,5,7,7,8,9,10" & @CRLF & _
"1,2,3" & @CRLF & _
"1,2,3,4,5,6,7" & @CRLF & _
"1,2,3,4,5,7,7,8,9,10" & @CRLF & _
"1,2,3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")