import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^,\\r\\n]*,){6}.*\\r?\\n(?:[^,\\r\\n]*,){9}.*(?:\\r?\\n(?!(?:[^,\\r\\n]*,){6}.*\\r?\\n(?:[^,\\r\\n]*,){9}).*)*";
final String string = "LB,32736,0,T,NRJ.POMPES_BACHE.PUISSANCE_ELEC_INST,20190811T080000.000Z,20190811T194400.000Z\n"
+ "TR,NRJ.POMPES_BACHE.PUISSANCE_ELEC_INST,0,65535,1,1,,0,0,2\n"
+ "20190811T080000.000Z,0.00800000037997961,192\n"
+ "20190811T080100.000Z,0.008999999612569809,192\n"
+ "20190811T080200.000Z,0.008999999612569809,192\n"
+ "LB,32734,0,T,NRJ.POMPES_BACHE.PUISSANCE_ELEC_CPT,20190811T080000.000Z,20190811T201200.000Z\n"
+ "TR,NRJ.POMPES_BACHE.PUISSANCE_ELEC_CPT,0,65535,1,1,,0,0,2\n"
+ "20190811T080000.000Z,0.6743068099021912,192\n"
+ "20190811T080100.000Z,0.6744459867477417,192\n"
+ "20190811T080200.000Z,0.6745882630348206,192\n"
+ "20190811T080300.000Z,0.6747232675552368,192\n"
+ "20190811T080400.000Z,0.6748600006103516,192\n"
+ "20190811T080500.000Z,0.6749916672706604,192\n"
+ "20190811T080600.000Z,0.6751362681388855,192\n\n"
+ "1,2,3,4,5,6,7\n"
+ "1,2,3,4,5,7,7,8,9,10\n"
+ "1,2,3\n"
+ "1,2,3,4,5,6,7\n"
+ "1,2,3,4,5,7,7,8,9,10\n"
+ "1,2,3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}