using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[א-ת]";
string input = @"# Note that our regular expression range is written right to left!
א
ב
ג
ד
ה
ו
ז
ח
ט
י
ך
כ
ל
ם
מ
ן
נ
ס
ע
ף
פ
ץ
צ
ק
ר
ש
ת";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}