import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[א-ת]";
final String string = "# Note that our regular expression range is written right to left!\n\n"
+ "א\n"
+ "ב\n"
+ "ג\n"
+ "ד\n"
+ "ה\n"
+ "ו\n"
+ "ז\n"
+ "ח\n"
+ "ט\n"
+ "י\n"
+ "ך\n"
+ "כ\n"
+ "ל\n"
+ "ם\n"
+ "מ\n"
+ "ן\n"
+ "נ\n"
+ "ס\n"
+ "ע\n"
+ "ף\n"
+ "פ\n"
+ "ץ\n"
+ "צ\n"
+ "ק\n"
+ "ר\n"
+ "ש\n"
+ "ת";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}