# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[א-ת]"
test_str = ("# Note that our regular expression range is written right to left!\n\n"
"א\n"
"ב\n"
"ג\n"
"ד\n"
"ה\n"
"ו\n"
"ז\n"
"ח\n"
"ט\n"
"י\n"
"ך\n"
"כ\n"
"ל\n"
"ם\n"
"מ\n"
"ן\n"
"נ\n"
"ס\n"
"ע\n"
"ף\n"
"פ\n"
"ץ\n"
"צ\n"
"ק\n"
"ר\n"
"ש\n"
"ת")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.